Class: Sketchup::Curve
Overview
The Curve class is used by SketchUp to unite a series of Edge objects into one conceptual entity. Since SketchUp is a surface modeler, all circles, arcs, and arbitrary curves are really just edges that are bound together in sequence.
There is a subclass of Curve called ArcCurve, which is any curve that makes up part of a circle. You can think of ArcCurves as entities that were created with SketchUp's Arc or Circle drawing tools and Curves as entities that were created with the Freehand drawing tool.
Direct Known Subclasses
Instance Method Summary # collapse
-
#count_edges ⇒ Object
The count_edges method is used to retrieve the number of Edge objects that make up the Curve.
-
#each_edge ⇒ Object
The each_edge method is used to iterate through all of the Edge objects in the curve.
-
#edges ⇒ Object
The edges method is used to retrieve an array of Edge objects that make up the Curve.
-
#first_edge ⇒ Object
The first_edge method is used to retrieve the first edge of the curve.
-
#is_polygon? ⇒ Boolean
True if this edge was originally created by the polygon tool, otherwise false.
-
#last_edge ⇒ Object
The last_edge method is used to retrieve the last edge of the curve.
-
#length ⇒ Length
The length method retrieves the length of the curve.
-
#move_vertices(point_array) ⇒ Boolean
The #move_vertices method moves the vertices in the curve to points.
-
#vertices ⇒ Object
The vertices method retrieves a collection of all vertices in a curve.
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #count_edges ⇒ Object
The count_edges method is used to retrieve the number of Edge objects that make up the Curve.
↑ #each_edge ⇒ Object
The each_edge method is used to iterate through all of the Edge objects in the curve.
↑ #edges ⇒ Object
The edges method is used to retrieve an array of Edge objects that make up the Curve.
↑ #first_edge ⇒ Object
The first_edge method is used to retrieve the first edge of the curve.
↑ #is_polygon? ⇒ Boolean
Returns True if this edge was originally created by the polygon tool, otherwise false.
↑ #last_edge ⇒ Object
The last_edge method is used to retrieve the last edge of the curve.
↑ #move_vertices(point_array) ⇒ Boolean
The #move_vertices method moves the vertices in the curve to points.
↑ #vertices ⇒ Object
The vertices method retrieves a collection of all vertices in a curve.