Class: Sketchup::ArcCurve
Overview
An ArcCurve is a Curve that makes up part of a circle. This is the underlying class for circles as well.
You can think of ArcCurves as entities that were created with SketchUp's Arc or Circle drawing tools and Curves as entities that were created with the Freehand drawing tool.
However, keep in mind that all Curves in SketchUp are really edges with some extra data attached to them. When you use the API to draw a Curve or ArcCurve, you are really drawing edges.
ArcCurve is a subclass of Curve, so all of the methods that are available to Curves are also available to ArcCurves.
Instance Method Summary # collapse
-
#center ⇒ Object
The center method is used to retrieve the Point3d that is at the center of the circular arc.
-
#circular? ⇒ Boolean
Checks if the ArcCurve is a circle.
-
#end_angle ⇒ Float
The #end_angle method is used to retrieve the angle of the end of the arc measured from the X axis in radians.
-
#normal ⇒ Object
The normal method retrieves a Vector3d that is perpendicular to the plane of the arc.
-
#plane ⇒ Object
The plane method is used to retrieve the plane of the arc.
-
#radius ⇒ Object
The radius method is used to retrieve the radius of the arc.
-
#start_angle ⇒ Object
The start_angle method is used to retrieve the angle of the start of the arc, measured from the X axis in radians.
-
#xaxis ⇒ Object
The xaxis method is used to retrieve the X axis of the coordinate system for the curve.
-
#yaxis ⇒ Object
The yaxis method is used to retrieve the Y axis of the coordinate system for the curve.
Methods inherited from Curve
#count_edges, #each_edge, #edges, #first_edge, #is_polygon?, #last_edge, #length, #move_vertices, #vertices
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #center ⇒ Object
The center method is used to retrieve the Point3d that is at the center of the circular arc.
↑ #circular? ⇒ Boolean
Checks if the ArcCurve is a circle.
↑ #end_angle ⇒ Float
A bug in SketchUp 2017 and older will report the end-angle for some circles as more than 360 degrees. In such case, subtract 2 * PI from the end angle value.
The #end_angle method is used to retrieve the angle of the end of the arc measured from the X axis in radians.
↑ #normal ⇒ Object
The normal method retrieves a Vector3d that is perpendicular to the plane of the arc.
↑ #plane ⇒ Object
The plane method is used to retrieve the plane of the arc.
Refer to the Geom module for instructions to create a plane.
↑ #radius ⇒ Object
The radius method is used to retrieve the radius of the arc.
↑ #start_angle ⇒ Object
The start_angle method is used to retrieve the angle of the start of the arc, measured from the X axis in radians.
↑ #xaxis ⇒ Object
The xaxis method is used to retrieve the X axis of the coordinate system for the curve. Note that the length of the returned vector is equal to the radius of the underlying curve.
↑ #yaxis ⇒ Object
The yaxis method is used to retrieve the Y axis of the coordinate system for the curve. Note that the length of the returned vector is equal to the radius of the underlying curve.