Class: Sketchup::Text
- Inherits:
-
Drawingelement
- Object
- Entity
- Drawingelement
- Sketchup::Text
Overview
The Text class contains method to manipulate a Text entity object.
Instance Method Summary # collapse
-
#arrow_type ⇒ Integer
The arrow_type method retrieves the current arrow type used for the leader text.
-
#arrow_type=(type) ⇒ Integer
The arrow_type= method sets the arrow type used for leader text.
-
#attached_to ⇒ Array(Sketchup::InstancePath, Geom::Point3d)?
The #attached_to method returns an array of the attached InstancePath object and the Geom::Point3d.
-
#attached_to=(path) ⇒ Object
The #attached_to= method will attach the Text to another DrawingElement.
-
#display_leader=(status) ⇒ Boolean
The display_leader= method accepts true or false for whether to display the leader.
-
#display_leader? ⇒ Boolean
The display_leader? method returns the status of the leader.
-
#has_leader? ⇒ Boolean
The has_leader method is used to determine if the Text object has a leader.
-
#leader_type ⇒ Integer
The leader_type method retrieves the currently set leader type.
-
#leader_type=(type) ⇒ Integer
The leader_type = method sets the leader type.
-
#line_weight ⇒ Integer
The line_weight method returns a line weight in number of pixels.
-
#line_weight=(weight) ⇒ Integer
The line_weight= method sets the line weight in pixels.
-
#point ⇒ Geom::Point3d
The point method is used to get the point associated with the text.
-
#point=(point3d) ⇒ Geom::Point3d
The point= method is used to set the point associated with the text.
-
#set_text(textstring) ⇒ Sketchup::Text
The set_text method is used to set the text within a Text object without recording an Undo operation.
-
#text ⇒ String
The text method is used to retrieve the string version of a Text object.
-
#text=(textstring) ⇒ String
The text= method is used to set the string version of a Text object.
-
#vector ⇒ Geom::Vector3d
The vector method is used to get the vector associated with the text.
-
#vector=(vector) ⇒ Geom::Vector3d
The vector= method is used to set the vector associated with the text.
Methods inherited from Drawingelement
#bounds, #casts_shadows=, #casts_shadows?, #erase!, #hidden=, #hidden?, #layer, #layer=, #material, #material=, #receives_shadows=, #receives_shadows?, #visible=, #visible?
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #arrow_type ⇒ Integer
The arrow_type method retrieves the current arrow type used for the leader text.
Valid arrow types are 0 for none, 2 for dot, 3 for closed arrow, 4 for open arrow.
↑ #arrow_type=(type) ⇒ Integer
The arrow_type= method sets the arrow type used for leader text.
Valid arrow types are 0 for none, 2 for dot, 3 for closed arrow, 4 for open arrow.
↑ #attached_to ⇒ Array(Sketchup::InstancePath, Geom::Point3d)?
The #attached_to method returns an array of the attached InstancePath object and the Geom::Point3d.
↑ #attached_to=(path) ⇒ Object
The #attached_to= method will attach the Sketchup::Text to another DrawingElement.
↑ #display_leader=(status) ⇒ Boolean
The display_leader= method accepts true or false for whether to display the leader.
Leader text that is not displayed is set to Hidden type.
↑ #display_leader? ⇒ Boolean
The display_leader? method returns the status of the leader.
↑ #has_leader? ⇒ Boolean
The has_leader method is used to determine if the Text object has a leader.
↑ #leader_type ⇒ Integer
The leader_type method retrieves the currently set leader type.
↑ #leader_type=(type) ⇒ Integer
The leader_type = method sets the leader type.
Valid leader types are 0 for none, 1 for View-based, and 2 for Pushpin
↑ #line_weight ⇒ Integer
The line_weight method returns a line weight in number of pixels.
Defalt line weight is 1.
↑ #line_weight=(weight) ⇒ Integer
The line_weight= method sets the line weight in pixels.
Default line weight is 1.
↑ #point ⇒ Geom::Point3d
The point method is used to get the point associated with the text.
↑ #point=(point3d) ⇒ Geom::Point3d
The point= method is used to set the point associated with the text.
↑ #set_text(textstring) ⇒ Sketchup::Text
The set_text method is used to set the text within a Text object without recording an Undo operation.
↑ #vector ⇒ Geom::Vector3d
The vector method is used to get the vector associated with the text.
↑ #vector=(vector) ⇒ Geom::Vector3d
The vector= method is used to set the vector associated with the text.