Class: Sketchup::Dimension
- Inherits:
-
Drawingelement
- Object
- Entity
- Drawingelement
- Sketchup::Dimension
Overview
The Dimension class provides base functionality for classes DimensionLinear and DimensionRadial. It's not instantiable.
Direct Known Subclasses
Constant Summary #
- Sketchup::Dimension::ARROW_NONE
- Sketchup::Dimension::ARROW_SLASH
- Sketchup::Dimension::ARROW_DOT
- Sketchup::Dimension::ARROW_CLOSED
- Sketchup::Dimension::ARROW_OPEN
Instance Method Summary # collapse
-
#add_observer(observer) ⇒ Object
The add_observer method is used to add a DimensionObserver to the dimension.
-
#arrow_type ⇒ Object
The arrow_type method retrieves the current arrow type of the dimension.
-
#arrow_type(type) ⇒ Object
The arrow_type= method sets the arrow type of the dimension.
-
#had_aligned_text=(value) ⇒ Object
The has_aligned_text= method accepts true or false indicating whether the dimension's text is aligned to the dimension or to the screen.
-
#has_aligned_text? ⇒ Boolean
The has_aligned_text method is used to determine whether the dimension's text is aligned to the dimension or to the screen.
-
#plane ⇒ Object
The plane method is used to retrieve the plane of the dimension.
-
#remove_observer(observer) ⇒ Object
The remove_observer method is used to remove a DimensionObserver from the dimension.
-
#text ⇒ Object
The text method is used to retrieve the dimension text.
-
#text=(text) ⇒ Object
The text= method is used to set an override on the dimension text.
Methods inherited from Drawingelement
#bounds, #casts_shadows=, #casts_shadows?, #erase!, #hidden=, #hidden?, #layer, #layer=, #material, #material=, #receives_shadows=, #receives_shadows?, #visible=, #visible?
Methods inherited from Entity
#attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #add_observer(observer) ⇒ Object
If the given observer responds to onTextChanged
, it will be added as a Sketchup::DimensionObserver. If not, the base Entity#add_observer will be called.
The add_observer method is used to add a DimensionObserver to the dimension.
↑ #arrow_type ⇒ Object
The arrow_type method retrieves the current arrow type of the dimension. Valid arrow types are class constants:
-
Dimension::ARROW_NONE,
-
Dimension::ARROW_SLASH
-
Dimension::ARROW_DOT
-
Dimension::ARROW_CLOSED
-
Dimension::ARROW_OPEN
↑ #arrow_type(type) ⇒ Object
The arrow_type= method sets the arrow type of the dimension. Valid arrow types are class constants:
-
Dimension::ARROW_NONE,
-
Dimension::ARROW_SLASH
-
Dimension::ARROW_DOT
-
Dimension::ARROW_CLOSED
-
Dimension::ARROW_OPEN
↑ #had_aligned_text=(value) ⇒ Object
The has_aligned_text= method accepts true or false indicating whether the dimension's text is aligned to the dimension or to the screen.
↑ #has_aligned_text? ⇒ Boolean
The has_aligned_text method is used to determine whether the dimension's text is aligned to the dimension or to the screen.
↑ #plane ⇒ Object
The plane method is used to retrieve the plane of the dimension. Refer to the Geom module for information on how planes are represented.
↑ #remove_observer(observer) ⇒ Object
The remove_observer method is used to remove a DimensionObserver from the dimension. Note that, if the given observer responds to 'onTextChanged', it will be removed as a DimensionObserver. If not, the base Entity.remove_observer will be called.
↑ #text ⇒ Object
The text method is used to retrieve the dimension text.
↑ #text=(text) ⇒ Object
The text= method is used to set an override on the dimension text.