Class: Sketchup::DimensionRadial

Inherits:
Dimension show all

Overview

The DimensionRadial class represents radius and diameter dimensions on arcs and circles.

Version:

  • SketchUp 2014

Constant Summary #

Constant Summary

Constants inherited from Dimension

Sketchup::Dimension::ARROW_CLOSED, Sketchup::Dimension::ARROW_DOT, Sketchup::Dimension::ARROW_NONE, Sketchup::Dimension::ARROW_OPEN, Sketchup::Dimension::ARROW_SLASH

Instance Method Summary # collapse

Methods inherited from Dimension

#add_observer, #arrow_type, #arrow_type=, #has_aligned_text=, #has_aligned_text?, #plane, #remove_observer, #text, #text=

Methods inherited from Drawingelement

#bounds, #casts_shadows=, #casts_shadows?, #erase!, #hidden=, #hidden?, #layer, #layer=, #material, #material=, #receives_shadows=, #receives_shadows?, #visible=, #visible?

Methods inherited from Entity

#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?

Instance Method Details

#arc_curveObject

The arc_curve method returns the ArcCurve object to which this dimension is attached.

Examples:

arc = dim.arc_curve

Returns:

  • The ArcCurve object to which the dimension is attached.

Version:

  • SketchUp 2014

#arc_curve=(arc_curve) ⇒ Object

The arc_curve= method is used to set the ArcCurve object to which this dimension is attached.

Examples:

dim.arc_curve = arc

Returns The ArcCurve object to which the dimension was attached.

Parameters:

  • arc_curve

    The ArcCurve object to which the dimension is to be attached.

Returns:

  • The ArcCurve object to which the dimension was attached.

Version:

  • SketchUp 2014

#leader_break_pointObject

The leader_break_point method returns the break point on the leader where the dimension text is attached.

Examples:

pt = dim.leader_break_point
puts "Break point is #{pt}"

Returns:

  • the leader break point

Version:

  • SketchUp 2014

#leader_break_point(point) ⇒ Object

The leader_break_point= method is used to set the break point on the leader where the dimension text is attached.

Examples:

dim.leader_break_point = [10, 0, 0]

Returns the point that was set.

Parameters:

  • point

    the point to be set

Returns:

  • the point that was set

Version:

  • SketchUp 2014

#leader_pointsObject

The leader_points method returns the 3 significant points along the dimension line in world coordinates.

Examples:

pts = dim.leader_points
puts "Break point is #{pts[0]}"
puts "Attach point is #{pts[1]}"
puts "Opposite point is #{pts[2]}"

Returns:

  • Array of 3 Point3d objects. Point 0: leader break point, where the text extension attaches. Point 1: attach point, where leader touches the arc/circle. Point 2: opposite point, where the diameter leader touches the circle on the opposite side.

Version:

  • SketchUp 2014