Class: Sketchup::Style

Inherits:
Entity
  • Object
show all

Overview

The Style class contains methods for modifying information about a specific style. Styles are a collection of display settings that tell SketchUp how to draw the model.

Examples:

styles = Sketchup.active_model.styles
puts "Your first style is named #{styles.first.name}"

Version:

  • SketchUp 6.0

Instance Method Summary # collapse

Methods inherited from Entity

#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?

Instance Method Details

#descriptionString

The #description method gets the description for a Sketchup::Style.

Examples:

styles = Sketchup.active_model.styles
style = styles.first
puts "Your first style description is: #{style.description}"

Returns:

Version:

  • SketchUp 6.0

#description=(description) ⇒ Object

The #description= method sets the description for a Sketchup::Style.

Examples:

styles = Sketchup.active_model.styles
style = styles.first
style.description = "My new style description."

Parameters:

Version:

  • SketchUp 6.0

#nameString

The #name method gets the name for a Sketchup::Style.

Examples:

styles = Sketchup.active_model.styles
style = styles.first
name = style.name

Returns:

Version:

  • SketchUp 6.0

#name=(name) ⇒ Object

The #name= method sets the name for a Sketchup::Style.

Examples:

styles = Sketchup.active_model.styles
style = styles.first
style.name = 'My Very Own Style'

Parameters:

Version:

  • SketchUp 6.0