Class: String

Inherits:
Object
  • Object
show all

Overview

The String class contains a method used to parse a string as a length value. All string arguments in Ruby API expect utf-8 strings.

Version:

  • SketchUp 6.0

Instance Method Summary # collapse

Instance Method Details

#to_lLength

The to_l method is used to convert a string to a length. The returned length is expressed in the Model units.

Examples:

length = "5'".to_l

Returns:

  • (Length)

    the length value

Version:

  • SketchUp 6.0