Class: Sketchup::LineStyles

Inherits:
Entity
  • Object
show all
Includes:
Enumerable

Overview

Provides access to the different line style objects in the model.

Version:

  • SketchUp 2019

Instance Method Summary # collapse

Methods inherited from Entity

#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?

Instance Method Details

#[](name) ⇒ Sketchup::LineStyle? #[](index) ⇒ Sketchup::LineStyle?

The #[] method lets you retrieve a line style by name or index.

The #at method is an alias of #[].

Examples:

solid_style = Sketchup.active_model.line_styles["Solid Basic"]
line_style = Sketchup.active_model.line_styles[1]

Overloads:

  • #[](name) ⇒ Sketchup::LineStyle?

    Parameters:

    • name (String)

      The name of the line style to retrieve.

  • #[](index) ⇒ Sketchup::LineStyle?

    Parameters:

    • index (Integer)

      The index of the line style to retrieve.

    Raises:

    • (IndexError)

      If index is out of bounds.

Returns:

  • (Sketchup::LineStyle, nil)

    The line style retrieved. nil if the name couldn't be retrieved.

Version:

  • SketchUp 2019

#[](name) ⇒ Sketchup::LineStyle? #[](index) ⇒ Sketchup::LineStyle?

The #[] method lets you retrieve a line style by name or index.

The #at method is an alias of #[].

Examples:

solid_style = Sketchup.active_model.line_styles["Solid Basic"]
line_style = Sketchup.active_model.line_styles[1]

Overloads:

  • #[](name) ⇒ Sketchup::LineStyle?

    Parameters:

    • name (String)

      The name of the line style to retrieve.

  • #[](index) ⇒ Sketchup::LineStyle?

    Parameters:

    • index (Integer)

      The index of the line style to retrieve.

    Raises:

    • (IndexError)

      If index is out of bounds.

Returns:

  • (Sketchup::LineStyle, nil)

    The line style retrieved. nil if the name couldn't be retrieved.

Version:

  • SketchUp 2019

#each {|linestyle| ... } ⇒ nil

The #each method is used to iterate through all the line styles.

Examples:

line_styles = Sketchup.active_model.line_styles
line_styles.each{ |line_style| p line_style.name }

Yield Parameters:

Returns:

  • (nil)

Version:

  • SketchUp 2019

#namesArray<String>

The #names method return the support line styles as strings.

Returns:

Version:

  • SketchUp 2019

#sizeInteger Also known as: length

The #size method returns the number of line styles that SketchUp supports.

Examples:

line_styles = Sketchup.active_model.line_styles
line_styles.size

Returns:

  • (Integer)

    The count of line styles.

Version:

  • SketchUp 2019

#to_aArray

The #to_a method returns an array of all the line styles.

Examples:

line_styles = Sketchup.active_active_model.line_styles.to_a

Returns:

  • (Array)

    Containing all the line style objects.

Version:

  • SketchUp 2019