Class: Sketchup::ShadowInfo
Overview
The ShadowInfo class contains method to extract the shadow information for a model. The majority of the shadow information returned exists in the Model Info > Location and Model Info > Shadows dialogs inside SketchUp.
The following shadow information keys are maintained in SketchUp:
-
City
(in Model Info > Geo-location > Set Manual Location…) Note that 'City' is called 'Location' in the UI -
Country
(in Model Info > Geo-location > Set Manual Location…) -
Dark
(in Window > Shadows) -
DayOfYear
-
DaylightSavings
-
DisplayNorth
-
DisplayOnAllFaces
(in Window > Shadows) -
DisplayOnGroundPlane
(in Window > Shadows) -
DisplayShadows
(in Window > Shadows) -
EdgesCastShadows
(in Window > Shadows) -
Latitude
(in Model Info > Geo-location > Set Manual Location…) -
Light
(in Window > Shadows) -
Longitude
(in Model Info > Geo-location > Set Manual Location…) -
NorthAngle
-
ShadowTime
(in Window > Shadows) -
ShadowTime_time_t
(ShadowTime in Epoch time) -
SunDirection
(Generated based on ShadowTime) -
SunRise
(Generated based on ShadowTime) -
SunRise_time_t
(SunRise in Epoch time) -
SunSet
(Generated based on ShadowTime) -
SunSet_time_t
(SunSet in Epoch time) -
TZOffset
(in Window > Shadows) -
UseSunForAllShading
(in Window > Shadows)
You access the ShadowInfo object by calling Model#shadow_info:
Class Method Summary # collapse
-
.each_key {|key| ... } ⇒ nil
The #each_key method iterates through all of the shadow information keys.
-
.keys ⇒ Array<String>
The keys method is a class method that returns an array with all of the attribute keys.
Instance Method Summary # collapse
-
#[](key) ⇒ Object?
The [] method retrieves a value from the array of keys.
-
#[]=(key, value) ⇒ Object
The set value []= method is used to set the value in the array of shadow info options.
-
#add_observer(observer) ⇒ Boolean
The add_observer method is used to add an observer to the current object.
-
#count ⇒ Integer
The count method is inherited from the Enumerable mix-in module.
-
#each {|key, value| ... } ⇒ nil
The #each method iterates through all of the shadow information key/value pairs.
-
#each_key {|key| ... } ⇒ nil
The #each_key method iterates through all of the shadow information keys.
-
#each_pair {|key, value| ... } ⇒ nil
The #each_pair method is an alias for #each.
-
#keys ⇒ Array<String>
The keys method is a class method that returns an array with all of the attribute keys.
-
#length ⇒ Integer
The #length method returns the number of options in the shadow options collection.
-
#remove_observer(observer) ⇒ Boolean
The remove_observer method is used to remove an observer from the current object.
- #size ⇒ Integer
Methods inherited from Entity
#attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #set_attribute, #to_s, #typename, #valid?
Class Method Details
Instance Method Details
↑ #[](key) ⇒ Object?
The [] method retrieves a value from the array of keys
↑ #[]=(key, value) ⇒ Object
The set value []= method is used to set the value in the array of shadow info options.
↑ #add_observer(observer) ⇒ Boolean
The add_observer method is used to add an observer to the current object.
↑ #count ⇒ Integer
The count method is inherited from the Enumerable mix-in module.
↑ #each {|key, value| ... } ⇒ nil
The #each method iterates through all of the shadow information key/value pairs.
↑ #each_key {|key| ... } ⇒ nil
The #each_key method iterates through all of the shadow information keys.
↑ #each_pair {|key, value| ... } ⇒ nil
The #each_pair method is an alias for #each.
↑ #keys ⇒ Array<String>
The keys method is a class method that returns an array with all of the attribute keys
↑ #length ⇒ Integer
The #length method returns the number of options in the shadow options collection
↑ #remove_observer(observer) ⇒ Boolean
The remove_observer method is used to remove an observer from the current object.