Class: Sketchup::Loop
Overview
Loop is a low level topology class that will not need to be used often. A Loop is a chain of Edges that bound a Face.
Instance Method Summary # collapse
-
#convex? ⇒ Boolean
Determine if the loop is convex.
-
#edges ⇒ Object
Get an array of the edges that define the loop in an ordered sequence.
-
#edgeuses ⇒ Object
Get an array of the EdgeUse objects that define this loop in an ordered sequence.
-
#face ⇒ Object
Get the Face object that is bounded by this loop.
-
#outer? ⇒ Boolean
Determine if this is an outer loop.
-
#vertices ⇒ Object
Get an array of the vertices that define the loop in an ordered sequence.
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #convex? ⇒ Boolean
Determine if the loop is convex.
↑ #edges ⇒ Object
Get an array of the edges that define the loop in an ordered sequence.
↑ #edgeuses ⇒ Object
Get an array of the EdgeUse objects that define this loop in an ordered sequence.
↑ #face ⇒ Object
Get the Face object that is bounded by this loop.
↑ #outer? ⇒ Boolean
Determine if this is an outer loop. Each face has one outer loop, and will have one loop for each hole.
↑ #vertices ⇒ Object
Get an array of the vertices that define the loop in an ordered sequence.