Class: Sketchup::Layer
Overview
As of SketchUp 2020 “Layers” were renamed to “Tags” in the UI. The API retains the use of “Layer” for compatibility and is synonymous with “Tag”.
The Layer class contains methods modifying and extracting information for a layer.
By default, a SketchUp model has one layer, Layer 0 (Named “Untagged” in the UI since SketchUp 2020), which is the base layer. You can't delete or rename Layer 0. Unlike certain other CAD software packages, entities associated with different layers in SketchUp still intersect with each other. (If you want collections of entities to not intersect, place them in Groups instead.)
Layers are commonly used to organize your model and control the visibility of related groups and components. For example, you could make all of your wall and roof entities different groups, associate layers with those groups, and then hide those layers so as to display just the floor plan in the model.
Instance Method Summary # collapse
-
#<=>(layer2) ⇒ Integer
The #<=> method is used to compare two layers based on their names.
-
#==(other) ⇒ Object
The #== method is used to determine if two layers are the same.
-
#color ⇒ Sketchup::Color
The #color method is used to retrieve the color of the layer.
-
#color=(color) ⇒ Object
The #color= method is used to set the name of a layer.
-
#display_name ⇒ String
The #display_name method is used to retrieve the display name of the layer.
-
#folder ⇒ Sketchup::LayerFolder?
The #folder method is used to return the parent layer folder of a layer.
-
#folder=(parent) ⇒ Object
The #folder= method is used to set the parent layer folder of a layer.
-
#line_style ⇒ Sketchup::LineStyle?
The #line_style method retrieves the line style on this layer.
-
#line_style=(line_style) ⇒ Sketchup::Layer
The #line_style= method lets you set a specific line style to a layer.
-
#name ⇒ String
The #name method is used to retrieve the name of the layer.
-
#name=(name) ⇒ Object
The #name= method is used to set the name of a layer.
-
#page_behavior ⇒ Integer
The #page_behavior method is used to retrieve the visibility behavior of the layer for new pages and existing pages.
-
#page_behavior=(page_behavior) ⇒ Object
The #page_behavior= method is used to control the layer's visibility behavior on existing and new pages.
-
#visible=(visible) ⇒ Object
The #visible= method is used to set if the layer is visible.
-
#visible? ⇒ Boolean
The #visible? method is used to determine if the layer is visible.
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #<=>(layer2) ⇒ Integer
The #<=> method is used to compare two layers based on their names. This enables the Ruby Array#sort method to sort SketchUp layers.
↑ #color ⇒ Sketchup::Color
The #color method is used to retrieve the color of the layer.
↑ #display_name ⇒ String
The #display_name method is used to retrieve the display name of the layer.
↑ #folder ⇒ Sketchup::LayerFolder?
The #folder method is used to return the parent layer folder of a layer.
↑ #folder=(parent) ⇒ Object
The #folder= method is used to set the parent layer folder of a layer.
This will trigger onParentFolderChanged
in normal cases and onLayerChanged
during undo/redo.
↑ #line_style ⇒ Sketchup::LineStyle?
The #line_style method retrieves the line style on this layer.
↑ #line_style=(line_style) ⇒ Sketchup::Layer
The #line_style= method lets you set a specific line style to a layer
↑ #page_behavior ⇒ Integer
The #page_behavior method is used to retrieve the visibility behavior of the layer for new pages and existing pages. For example, you may want your layer to be visible or hidden by default in any new pages (aka Scenes) created by the user.
A page keeps a list of layers that do not have their default behavior. If a layer is not in that list, then it is set to its default visibility determined by one of these values:
The behaviour is composed of a combination of these flags:
- Default visibility
-
These flags are used to set the value of #page_behavior. A page keeps a list of layers that do not have their default behavior. If a layer is not in that list, then it is set to its default visibility which is determined by one of these flags.
-
LAYER_VISIBLE_BY_DEFAULT:
0x0000
-
LAYER_HIDDEN_BY_DEFAULT:
0x0001
-
- Visibility on new pages
-
You can also set this addition flag that controls the visibility of a layer on newly created pages.
-
LAYER_IS_VISIBLE_ON_NEW_PAGES:
0x0010
-
LAYER_IS_HIDDEN_ON_NEW_PAGES:
0x0020
The default visibility for a layer is set by either LAYER_VISIBLE_BY_DEFAULT or LAYER_HIDDEN_BY_DEFAULT. This is what will be used when a page does not contain the visibility state of a layer.
The remaining flags control the visibility of the layer for new pages.
↑ #page_behavior=(page_behavior) ⇒ Object
The #page_behavior= method is used to control the layer's visibility behavior on existing and new pages.
When you Update a page (as opposed to creating a new page) the current visibility of the layer is used.
The behavior is composed of a combination of these flags:
- Default visibility
-
These flags are used to set the value of #page_behavior. A page keeps a list of layers that do not have their default behavior. If a layer is not in that list, then it is set to its default visibility which is determined by one of these flags.
-
LAYER_VISIBLE_BY_DEFAULT:
0x0000
-
LAYER_HIDDEN_BY_DEFAULT:
0x0001
-
- Visibility on new pages
-
You can also set this addition flag that controls the visibility of a layer on newly created pages.
-
LAYER_IS_VISIBLE_ON_NEW_PAGES:
0x0010
-
LAYER_IS_HIDDEN_ON_NEW_PAGES:
0x0020