Class: Sketchup::Image
- Inherits:
-
Drawingelement
- Object
- Entity
- Drawingelement
- Sketchup::Image
Overview
An Image object represents a raster image placed in the Model.
Instance Method Summary # collapse
-
#explode ⇒ Object
The explode method is used to explode an image into a face with a texture on it.
-
#glued_to ⇒ Sketchup::Face, ...
The #glued_to method is used to retrieve the entity that this image is glued to.
-
#glued_to=(drawing_element) ⇒ Sketchup::Face, ...
The #glued_to= method glues this image to a drawing element.
-
#height ⇒ Object
The height method is used to retrieve the height of the image.
-
#height=(height) ⇒ Object
The height= method is used to set the height of the image.
-
#image_rep ⇒ Sketchup::ImageRep
The #image_rep method returns a copy of a ImageRep object representing the pixel data.
-
#normal ⇒ Object
The normal method is used to retrieve the 3D Vector that is perpendicular to the plane of the image.
-
#origin ⇒ Object
The origin method is used to retrieve the 3D point that defines the origin of the image.
-
#origin(point) ⇒ Object
The origin= method is used to set the 3D point as the origin of the image.
-
#path ⇒ Object
The path method is used to retrieve the path of the file defining the image.
-
#pixelheight ⇒ Object
The pixelheight method is used to retrieve the height of the image file in pixels.
-
#pixelwidth ⇒ Object
The pixelwidth method is used to retrieve the width of the image file in pixels.
-
#size=(width, height) ⇒ Object
The size= method is used to set the width and height of the image, in inches.
-
#transform!(transform) ⇒ Object
The transform! method is used to apply a transformation to the image.
-
#transformation ⇒ Object
The transformation method is used to retrieve the transformation for the image.
-
#transformation=(transform) ⇒ Object
The transformation= method is used to set the transformation for the image.
-
#width ⇒ Object
The width method is used to retrieve the width of the image.
-
#width=(width) ⇒ Object
The width= method is used to set the width of the image.
-
#zrotation ⇒ Object
The zrotation method is used to get the angle that the image is rotated about the normal vector from an arbitrary X axis.
Methods inherited from Drawingelement
#bounds, #casts_shadows=, #casts_shadows?, #erase!, #hidden=, #hidden?, #layer, #layer=, #material, #material=, #receives_shadows=, #receives_shadows?, #visible=, #visible?
Methods inherited from Entity
#add_observer, #attribute_dictionaries, #attribute_dictionary, #delete_attribute, #deleted?, #entityID, #get_attribute, #inspect, #model, #parent, #persistent_id, #remove_observer, #set_attribute, #to_s, #typename, #valid?
Instance Method Details
↑ #explode ⇒ Object
The explode method is used to explode an image into a face with a texture on it.
Note that current versions of SketchUp will return an empty array here. To work around this limitation you can iterate over your entities collection to determine which new entities were created.
Versions prior to SketchUp 2015 returned an empty array due to a bug.
↑ #glued_to ⇒ Sketchup::Face, ...
The #glued_to method is used to retrieve the entity that this image is glued to.
↑ #glued_to=(drawing_element) ⇒ Sketchup::Face, ...
The #glued_to= method glues this image to a drawing element. When moving this other drawing elment with the Move tool, the image moves with it.
↑ #height ⇒ Object
The height method is used to retrieve the height of the image.
The height is given in inches.
↑ #height=(height) ⇒ Object
The height= method is used to set the height of the image.
The height is set in inches.
↑ #image_rep ⇒ Sketchup::ImageRep
The #image_rep method returns a copy of a Sketchup::ImageRep object representing the pixel data.
↑ #normal ⇒ Object
The normal method is used to retrieve the 3D Vector that is perpendicular to the plane of the image.
↑ #origin ⇒ Object
The origin method is used to retrieve the 3D point that defines the origin of the image.
↑ #origin(point) ⇒ Object
The origin= method is used to set the 3D point as the origin of the image.
↑ #path ⇒ Object
The path method is used to retrieve the path of the file defining the image.
↑ #pixelheight ⇒ Object
The pixelheight method is used to retrieve the height of the image file in pixels.
↑ #pixelwidth ⇒ Object
The pixelwidth method is used to retrieve the width of the image file in pixels.
↑ #size=(width, height) ⇒ Object
The size= method is used to set the width and height of the image, in inches.
↑ #transform!(transform) ⇒ Object
The transform! method is used to apply a transformation to the image.
↑ #transformation ⇒ Object
The transformation method is used to retrieve the transformation for the image.
↑ #transformation=(transform) ⇒ Object
The transformation= method is used to set the transformation for the image.
↑ #width ⇒ Object
The width method is used to retrieve the width of the image.
The width is given in inches.
↑ #width=(width) ⇒ Object
The width= method is used to set the width of the image.
The width is set in inches.
↑ #zrotation ⇒ Object
The zrotation method is used to get the angle that the image is rotated about the normal vector from an arbitrary X axis.