Class: Sketchup::ClassificationSchema
- Inherits:
-
Object
- Object
- Sketchup::ClassificationSchema
- Includes:
- Comparable
Overview
The ClassificationSchema class represent schemas loaded in the model.
Instance Method Summary # collapse
-
#<=>(schema2) ⇒ Object
The <=> method is used to compare two ClassificationSchema objects for sorting.
-
#name ⇒ Object
The name method returns the name of the schema.
-
#namespace ⇒ Object
The namespace method returns the namespace of the schema.
Instance Method Details
↑ #<=>(schema2) ⇒ Object
The <=> method is used to compare two ClassificationSchema objects for sorting. The comparison is done based on the schema name.
↑ #name ⇒ Object
The name method returns the name of the schema.
↑ #namespace ⇒ Object
The namespace method returns the namespace of the schema.