Class: Sketchup::AppObserver Abstract

Inherits:
Object
  • Object
show all

Overview

This class is abstract.

To implement this observer, create a Ruby class of this type, override the desired methods, and add an instance of the observer to the application class.

This observer interface is implemented to react to application events. This interface is often used to attach other observers to models as they are opened or started. This ensures that your observers are watching all open models.

For example, when one attaches a SelectionObserver, it is only attached to the Selection collection of a given model. If a 2nd model is opened, the new model's selection changes will not fire selection callbacks unless you've attached a SelectionObserver to the new model as well. By watching for #onNewModel, you can be sure to do so.

Examples:

# This is an example of an observer that watches the application for
# new models and shows a messagebox.
class MyAppObserver < Sketchup::AppObserver
  def onNewModel(model)
    puts "onNewModel: #{model}"

    # Here is where one might attach other observers to the new model.
    model.selection.add_observer(MySelectionObserver.new)
  end
end

# Attach the observer
Sketchup.add_observer(MyAppObserver.new)

Version:

  • SketchUp 6.0

Instance Method Summary # collapse

Instance Method Details

#expectsStartupModelNotificationsBoolean

Note:

Prior to SketchUp 2014, #onNewModel and #onOpenModel were not being called for the startup models. This issue is now fixed but observers still need to express their intent to receive these calls. This is for back-compatibility with existing scripts which worked around these missing calls by other means. For new code, this method should be implemented and should return true.

The #expectsStartupModelNotifications method is called to determine if the observer expects to receive #onNewModel and #onOpenModel calls for the models that are created or opened at SketchUp startup. This includes the empty initial model, a model opened via command line arguments, or auto-restored models on Mac OS X.

Examples:

def expectsStartupModelNotifications
  return true
end

Returns:

  • (Boolean)

    true to receive #onNewModel and #onOpenModel calls for startup models. Return false or simply not implement the method in order to not receive these calls (which was the behavior prior to SketchUp 2014).

Version:

  • SketchUp 2014

#onActivateModel(model) ⇒ nil

The #onActivateModel method is called when an open model is activated. This is relevant on Mac only which supports multiple documents to be opened simultaneously.

Examples:

def onActivateModel(model)
  puts "onActivateModel: #{model}"
end

Parameters:

Returns:

  • (nil)

Version:

  • SketchUp 2015

#onExtensionsLoadedObject

The #onExtensionsLoaded method is called when SketchUp has finished loading all extensions when the application starts.

Examples:

def onExtensionsLoaded
  puts "onExtensionsLoaded"
end

Version:

  • SketchUp 2022.0

#onNewModel(model) ⇒ nil

The #onNewModel method is called when the application creates a new, empty model.

Examples:

def onNewModel(model)
  puts "onNewModel: #{model}"
end

Parameters:

Returns:

  • (nil)

Version:

  • SketchUp 6.0

#onOpenModel(model) ⇒ nil

Note:

If a skp file is loaded via the command line or double-clicking on a skp in explorer (which is also is the command line) then this observer will not be called. The Ruby interpreter in SketchUp is initialized after command line processing so the observer won't be added in time to get the notification.

The #onOpenModel method is called when the application opens an existing model.

Examples:

def onOpenModel(model)
  puts "onOpenModel: #{model}"
end

Parameters:

Returns:

  • (nil)

Version:

  • SketchUp 6.0

#onQuitnil

The #onQuit method is called when SketchUp closes. This is useful if you need to clean up anything or store your application state upon close.

Examples:

def onQuit()
  puts "onQuit"
end

Returns:

  • (nil)

Version:

  • SketchUp 6.0

#onUnloadExtension(extension_name) ⇒ nil

The #onUnloadExtension method is called when the user turns off a Ruby extension. This is useful for detecting if the user is deactivating some critical set of observers, for example, so you can warn them or cache your extension state.

Examples:

def onUnloadExtension(extension_name)
  puts "onUnloadExtension: #{extension_name}"
end

Parameters:

  • extension_name (String)

    The name of the extension just unloaded.

Returns:

  • (nil)

Version:

  • SketchUp 7.0