Class: Layout::TableRow

Inherits:
Object
  • Object
show all

Overview

A TableColumn is a single row from a table.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
rows.times { |index|
  row = table.row(index)
}

Version:

  • LayOut 2018

Instance Method Summary # collapse

Instance Method Details

#bottom_edge_styleLayout::Style

The #bottom_edge_style method returns the Style of a Layout::TableRow's bottom edge.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
style = table.get_row(1).bottom_edge_style

Returns:

Version:

  • LayOut 2018

#bottom_edge_style=(style) ⇒ Object

The #bottom_edge_style= method sets the Style of a Layout::TableRow's bottom edge.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
style = Layout::Style.new
style.stroke_width = 2.0
table.get_row(1).bottom_edge_style = style

Parameters:

Raises:

Version:

  • LayOut 2018

#heightFloat

The #height method returns the height of the Layout::TableRow.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
height = table.get_row(1).height

Returns:

  • (Float)

Version:

  • LayOut 2018

#height=(height) ⇒ Object

The #height= method sets the height of the Layout::TableRow.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
table.get_row(1).height = 3.0

Parameters:

  • height (Float)

Raises:

Version:

  • LayOut 2018

#top_edge_styleLayout::Style

The #top_edge_style method returns the Style of a Layout::TableRow's top edge.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
style = table.get_row(1).top_edge_style

Returns:

Version:

  • LayOut 2018

#top_edge_style=(style) ⇒ Object

The #top_edge_style= method sets the Style of a Layout::TableRow's top edge.

Examples:

bounds = Geom::Bounds2d.new(1, 1, 4, 4)
rows = 4
columns = 4
table = Layout::Table.new(bounds, rows, columns)
style = Layout::Style.new
style.stroke_width = 2.0
table.get_row(1).top_edge_style = style

Parameters:

Raises:

Version:

  • LayOut 2018