Class: Sketchup::Http::Response

Inherits:
Object
  • Object
show all

Overview

Note:

Do not Sketchup::Http::Request#cancel the request in the response callback.

Response objects allows you to get the response information from the server, you can only receive the Response if you have attached a callback block when calling start from the Request object.

Version:

  • SketchUp 2017

Instance Method Summary # collapse

  • #body ⇒ String

    Gets the HTTP body that was received from the server as a string encoded using the charset provided in the “Content-Type” header of the server response, if no charset is specified, Encoding::ASCII_8BIT will be used.

  • #headers ⇒ Hash

    Returns the HTTP headers that were sent by the server.

  • #status_code ⇒ Integer

    Returns the HTTP response status code as defined in rfc2616.

Instance Method Details

#bodyString

Gets the HTTP body that was received from the server as a string encoded using the charset provided in the “Content-Type” header of the server response, if no charset is specified, Encoding::ASCII_8BIT will be used.

Examples:

@request = Sketchup::Http::Request.new("http://localhost:8080")

@request.start do |request, response|
  puts "body: " + response.body
end

Returns:

Version:

  • SketchUp 2017

#headersHash

Returns the HTTP headers that were sent by the server.

Examples:

@request = Sketchup::Http::Request.new("http://localhost:8080")

@request.start do |request, response|
  response.headers.each do |key, value|
    puts "#{key}: #{value}"
  end
end

Returns:

  • (Hash)

Version:

  • SketchUp 2017

#status_codeInteger

Returns the HTTP response status code as defined in rfc2616.

Examples:

@request = Sketchup::Http::Request.new("http://localhost:8080")

@request.start do |request, response|
  puts "HTTP status code: #{response.status_code}"
end

Returns:

  • (Integer)

Version:

  • SketchUp 2017