Class: Sketchup::Console
- Inherits:
-
Object
- Object
- Sketchup::Console
Overview
The Console class is used by SketchUp to direct $stdout and $stderr to the Ruby Console. It is a singleton class that only has one instance available. This instance is accessible via the SKETCHUP_CONSOLE constant.
In SketchUp 2014 methods were added to allow developers to control the visibility of the Ruby Console.
Also note that in SketchUp 2014, writing to the console does not work from within Ruby threads other than the main thread. So the following code will not produce any output.
Instance Method Summary # collapse
-
#clear ⇒ Object
Clears the contents of SketchUp's Ruby Console.
-
#hide ⇒ Object
Hides the SketchUp Ruby Console.
-
#show ⇒ Object
Displays the SketchUp Ruby Console.
-
#visible? ⇒ Boolean
Returns the visibility state of the SketchUp Ruby Console.