Class: Layout::Ellipse

Inherits:
Entity
  • Object
show all

Overview

A simple elliptical shape entity.

Version:

  • LayOut 2018

Instance Method Summary # collapse

Methods inherited from Entity

#==, #bounds, #document, #drawing_bounds, #group, #layer_instance, #locked=, #locked?, #move_to_group, #move_to_layer, #on_shared_layer?, #page, #style, #style=, #transform!, #transformation, #untransformed_bounds, #untransformed_bounds=

Constructor Details

#initialize(bounds) ⇒ Layout::Ellipse

The #initialize method creates a new Layout::Ellipse.

Examples:

upper_left = Geom::Point2d.new(1, 1)
lower_right = Geom::Point2d.new(2, 2)
bounds = Geom::Bounds2d.new(upper_left, lower_right)
ellipse = Layout::Ellipse.new(bounds)

Parameters:

Raises:

  • ArgumentError if bounds is zero size

Version:

  • LayOut 2018